Dedicated Server Control Panel [NON IMPACTING]
Scheduled for February 12, 2026 at 7:00 AM – 3:47 PM
Affects
Dedicated Server Control Panel
Under maintenance from 7:00 AM to 3:47 PM
Completed
February 12, 2026 at 3:47 PMCompleted
February 12, 2026 at 3:47 PMMaintenance has completed successfully.
Planned
February 12, 2026 at 7:00 AMPlanned
February 12, 2026 at 7:00 AMWe are performing some networking changes that, while they are not expected to impact our Dedicated Server Control Panel, may affect it.
In progress
February 12, 2026 at 6:56 AMIn progress
February 12, 2026 at 6:56 AMMaintenance is now in progress.